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Chapter 1
1 Welcome to FEA

This guide assumes that you are new to LISA and indeed may be new to finite element analysis. Here 
you will find a simple account to give you the overall picture and get you started using the program. 
Once you have learned the basic concepts and operations, you will be ready to advance your skills 
with the more sophisticated features described in the companion ‘Tutorials and Reference Guide’.  

1.1  Simple overview of the Finite Element Method
Suppose you want to solve a physical problem such as finding the stresses in an object when some 
prescribed forces are applied. This is a typical problem for FEA: some type of ‘force’ is applied to an 
object and the response calculated subject to specified constraints. This is the usual structure:

In a mechanics problem the object might be a gear wheel, the force might be applied from another  
gear, the response might be the tensile and shear stresses throughout the gear wheel and on the 
supporting shaft. The constraint is that the gear must remain on the shaft.

In an electrostatic  problem, the object might be a specially shaped capacitor, the force might be the 
voltage applied to the anode, the constraint that the cathode is earthed, and the response might be the 
stored charge and the polarization throughout the material.

The model you build must represent the object plus all these forces, constraints and  materials. At the 
end of the calculation the software will display the results, and then you have to interpret them.
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The finite element method is a numerical technique for gaining an approximate answer to the problem 
by representing the object by an assembly of rods, plates, blocks, bricks – the finite elements --  rather 
like  a  child’s  Lego® model.   Each  of  these  building  elements  is  given  the  appropriate  material 
properties and is connected to adjacent elements at ‘nodes’ – special points on the ends, edges and 
faces of the element.  Selected nodes will be given constraints to fix them in position, temperature, 
voltage, etc. depending on the problem. The physics of the situation is built into each element through 
a variational principle to minimize energy.

Mathematically the assemblage of nodes is represented as a very large matrix.  The technique solves 
a matrix equation

[Node matrix describing object and constraints] × [Response] = [Applied ‘force’]

The resulting [Response] matrix must then be converted into tables and graphs of values for the user 
to make use of.

Because the ‘Lego®’ bricks can easily be assembled into complicated shapes, FEA is a popular and 
powerful  method  for  realistically  predicting  the  behavior  of  many  engineering  structures  and 
components.  Computer graphics are used throughout the method to display the model and results.

The finite element method, therefore, has three main stages:
1) build the model
2) solve the model
3) display the results

These can be broken down further:
 Build the model 

o create nodes in positions to represent the object’s shape
 either create in LISA or
 import from an existing CAD model 
 refine as required.

o create finite elements (beams, plates, bricks, etc) between the nodes
o assign material properties to the elements
o assign constraints to selected nodes
o assign applied forces to the appropriate nodes.

 Solve the model
o define  the  type  of  analysis  you  want  e.g.  static  linear,  vibrational  modes,  dynamic 

response with time, etc.
o let LISA’s Solver do the work.    

 Display the results
o open  the  results  file  and  select  which  parameters  you  want  to  display  e.g. 

displacement, principal stress, temperature, voltage, 
o display as 2D or 3D contour plots, and/or as tables of numerical values,
o before inferring anything from the results, they must first be validated,
o validation requires confirming mesh convergence has occurred and that values are in 

line with expectations from hand calculations, experiments or past experience,
o mesh convergence requires refining the mesh repeatedly and solving until the results 

no longer change appreciably.
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1.2  Basic operations in the graphics area

Because the graphics is so much a part of LISA, let us look first at a data file which displays a model 
and its solution.

1.2.1   Basic graphics tutorial

Step 1

File->Open, 1.2.1_basic_graphics_tutorial.liml in the tutorials folder where LISA has been installed. 
This is a contrived example merely to show the graphics features.

There are three parts to the screen
 the toolbars at the top, arranged into model-building tools and the graphics display options.
 the model structure and solution displayed in an outline tree in the left panel
 a graphic display area of the model

This sample is a beam with a T-shaped end and has already been solved.  One end is totally fixed, as 
if built into a wall.  At the free end a  downwards force is applied at seven locations.  The self-weight of 
the beam has been neglected.
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Step 2

 Toggle the display of element surfaces.

Toggle element edge display.

Step 3

Select nodes

Drag over the model to see that 
nodes have been selected.

Click in an open space to deselect the nodes.
Then left click a node to select it.  Hold the 
Ctrl key down and click a couple of nodes to 
add to the selection set. If a node is already 
selected and it's clicked on while holding 
down the Ctrl key, it becomes deselected.

Left click to select a node, but keep the mouse 
button pressed and drag the node to a new 
location. Repeat the action on another node, 
but this time hold down the Shift key. You'll 
notice that the node is fixed and cannot be 
dragged.

Edit->Undo or Ctrl + Z to return the displaced node.
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Click in an open space to deselect the nodes. 

 Select faces. Drag over the model to see 
that only surfaces are selected.

Click in an open space to deselect the surfaces.

Select  elements.   Drag  to  see  that  only 
elements have been selected.

The Ctrl key has the same effect while selecting faces or elements as it does with selecting nodes.

Step 4

The display of loads and constraints can be 
toggled off or on.

Step 5

Click the Z arrowhead of the triad at the bottom right corner of the graphics area to view 
the model parallel to the screen.

Left  or  right  clicking the arrowheads 
will display the different views of the 
model parallel to the screen.
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Click the blue dot to return to an isometric view.

Step 6

Not all of a model's features can be displayed at the same time in the graphics area. Features hidden 
behind need to be rotated into view. To do this press down and hold the mouse middle button (the 
mouse middle button is the roller wheel between the left and right mouse buttons) and rotate the 
models display in the graphics area.

To see a small feature more clearly, zoom into that area by placing the mouse over that area (no 
clicking required) and rotate the mouse wheel for a larger display of the small feature. Rotating the 
mouse wheel the other way will make the model's display become smaller.

If the model's display seems to be half out of the graphics area, 
you  need  to  pan  the  model  back  into  view.  Right  click  the 
mouse, keep the button pressed and move until  the model is 
completely visible. 

If the model does not fully appear in the graphics area after you have used the zoom, rotate or pan , 
use the fit to screen tool-button 

Step 7

Use the tape measure tool-button to  check the lengths.  Click  a  node  but  continue  keeping the 
mouse button pressed and move the cursor across to another node. LISA will give a readout of that 
distance.

Step 8

Tools->Volume will give volume of the entire mesh. This tool can be used to obtain the volume of a 
selected part of the mesh. The selection can be element nodes, faces or elements.

Similarly the Tool->Surface area will give the area of the selected faces. The selections can only be 
element faces.
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1.2.2   Solution tutorial

Step 1

This tutorial uses the same file as the previous tutorial. So if it is not already open in LISA, use the 
File->Open, 1.2.1_basic_graphics_tutorial.liml in the tutorials folder where LISA has been installed.

In the solution section of the outline tree click on Displacement in Y.  The graphics display will update 
to show the results of the solved model. The units used in the legend on the display scale are shown 
without dimensions.  It is up to the user to select and work within a consistent set of dimensions such 
a SI or Imperial units.  In this case, if 1 unit in the model represents 1 meter in reality, then -9.037E-05 
units means a displacement of 0.09037 mm in the negative y direction.

Step 2

Click the view deformed tool-button to  visualize an exaggerated displacement of the structure.

Click  the undeformed mesh on/off  to superimpose an outline of the undeformed mesh onto the 
deformed mesh.

Click view undeformed to no longer view the exaggerated displacement.
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Step 3

Click the table tool-button to display the displacements, rotations and stresses at each node in 
spreadsheet-style cells which you can then copy and paste into your own spreadsheet.

Step 4

Use the animation tool-button to animate the deflection.  Smooth  deformation between the two 
extremes of movement is simulated. You can choose the scale factor. This tool is especially useful for 
visualizing solutions in vibration analysis.

Step 5

This slider can be used to cut-away the model to look inside it.  You will  need to 
rotate the model suitably so that the cut occurs where you want it. Don't forget to 

return to its leftmost position before doing any editing of the mesh.

To return to the model that does not display the results, click any of the items in the outline tree that is  
not below Solution. 

Now that you have some experience in manipulating the graphics of the model, it’s time to learn how 
to create them from scratch.  The next section will walk you through the case we have just studied.
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Chapter 2
2 Modeling

2.1  The finite element model

This chapter will explain how to use the tools that are available in LISA for creating your finite element 
model.  Unlike computer aided design (CAD) software which uses lines, surfaces and solids, finite 
element analysis software uses only nodes and elements. It is also possible to import CAD models 
into LISA and create a suitable mesh with LISA's automeshing tools, but this is described in the more 
advanced Tutorials and Reference Guide installed with LISA.

A finite element model is a mesh of elements. Each element has nodes which are simply points on the 
element.  Elements  can  only  be  connected  to  other  elements  node-to-node.  An  element  edge-to-
element-node  is  no  connection  at  all.  Elements  themselves  have  very  simple  shapes  like  lines, 
triangles, squares, cubes and pyramids. 

Each element is formulated to obey a particular law of science. For example in static analysis, the 
elements are formulated to relate displacement and stress according to the theory of mechanics of 
materials. In the case of modal vibration the elements are formulated to obey deflection shapes and 
frequencies according to the theory of structural dynamics. Similarly, in thermal analysis the elements 
relate temperature and heat according to heat transfer theory.  So it  is essential that you have an 
understanding of the underlying physics theory before using finite element analysis software.  

When beginning a new model first check whether or not your choice of element shape is actually 
supported by the type of analysis. The element shapes that are available to each type of analysis are 
listed in the accompanying Tutorials and Reference Guide installed with LISA. That manual contains 
technical details which you can refer to later.
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2.2  Manual meshing

Always begin a manual mesh by creating a coarse mesh; it can always be refined later. A coarse mesh 
simply means larger and fewer elements, and a refined mesh means smaller and more elements. 
Creating a coarse mesh requires less labor and, if things go wrong, it will be less frustrating. 

Just  as  in  the  real  world  where  everything  has  three  dimensions  (length,  width,  height),  the 
geometrical properties of finite elements are also three dimensional in nature. Some elements will 
appear on the screen as being clearly three dimensional elements, while others will appear on the 
screen as flat and two dimensional. Nevertheless, the elements that appear flat and two dimensional 
do actually have the third dimension, of thickness.

Elements that appear three dimensional on the screen will usually be created from a two dimensional 
flat shape, so modeling typically starts with what appears on the screen as a flat two dimensional 
mesh. This initial 2D mesh can be created either by a combination of nodes and elements or by using 
ready-made template patterns. Editing tools are available for modifying the two dimensional mesh as 
you create and form it. Once the coarse mesh is complete, whether it be two dimensional or three 
dimensional in appearance, it will need to be refined before running the Solver.

To summarize, the manual meshing tools can be grouped together by purpose:
i. creating tools, that bring into existence a two dimensional mesh
ii. editing tools, that form and modify the created two dimensional mesh
iii. tools that will convert the two dimensional mesh into three dimensional meshes
iv. refinement tools for converging results

Here  is  a  tutorial  to  illustrate  how  these  tools  work  together  to  create  the  model  used  in  the 
introductory chapter. We will recreate the T-shaped thick beam used in section 1.2 to illustrate LISA's 
graphics tools. At the end you may wish to use some of the skills you have learned to modify the 
length and thickness of the beam to make it more realistic.

2.2.1  T-shaped beam tutorial

Step 1

The analysis type should be Static 3D. If it's not, right click the item,  then select 
Edit to change the analysis type.

Use the Mesh tools->Create->Node... or and enter the following coordinates.
X 0
Y 0
Z 0

Click the Add button. Repeat for the following coordinates.
11,0,0
11,1,0
0,1,0

13



Click the Z arrowhead to view the XY plane parallel to the screen. 

To view the entire model, use fit to screen 

Step 2

Mesh  tools->Create->Element...  Select and click the four nodes. The order of the 
clicked nodes will affect the orientation of the mesh refinement that will be done in the next step. In this 
tutorial, the element is formed using the node order 1-2-3-4.

Step 3

Mesh tools->Refine->Custom...
Number of subdivisions
R 11
S 4
T 1

Step 4

Activate select faces

Drag to select the entire mesh.

Mesh tools->Extrude... 
Direction +Z
Thickness 2
Number of subdivisions 2
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Click the blue dot to view an isometric display of the model.

Click in the open space of the graphics area to deselect the 
elements.

Step 5

Activate select faces

To improve clarity use the show element surfaces tool-button to hide the internal elements.

Select  these two faces by clicking one face then holding the Ctrl key while 
clicking the second face.

The  Ctrl key can be used while selecting items. It works by adding the new items to the currently 
selected items, and if the clicked item is already selected it will become deselected.

Mesh tools->Extrude... 
Direction +Z
Thickness 1
Number of subdivisions 1

Click and hold down the mouse middle button (it's  the 
roller on the mouse used for scrolling, press and keep it 
pressed) to rotate the view of the model or use this 
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Activate select faces

Select these two faces.

Mesh tools->Extrude... 
Direction -Z
Thickness 1
Number of subdivisions 1

Step 6

Click in an open space of the graphics area to deselect the model.

Activate select nodes to see that these are 8 node hexahedrons. 

Change  these  8  node  hexahedrons  into  the  more  accurate  20  node 
hexahedrons  using  Mesh tools->Change  element  shape...  select  hex20 
and click OK to accept. The hex8 elements give a linear approximation to the 
stresses  and  strains,  whilst  the  hex20  elements  give  a  quadratic 
approximation.

Step 7

Right click,  Assign new material
Geometric tab
Thickness 1

Mechanical tab
Isotropic select
Young's modulus 20E10
Poisson's ratio 0.3
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A material is now associated with the elements.

Step 8

In order for a part to develop stresses, all rigid body motion must be resisted. The left face of this 
model will be constrained.

Activate select faces

Select this face.

Right click, select New fixed support accept the defaults and click OK
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Step 9

Activate select nodes and select these nodes. 

Hold the Ctrl key down while clicking to add the nodes 
so  that  the  nodes  already  selected  don't  become 
deselected.

Right click, select New force 
Y -35000

The  3500  force  will  be  divided  by  the 
number of selected nodes, which in this 
case is 7. So each node will  effectively 
have a load of 35000/7 or 5000.

Step 10

Before you run the Solver, check down the outline tree to make sure there are no warnings in red.

Click to solve the model. 

The results are listed in the outline tree below Solution. 
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You may now wish to explore LISA's mesh-modifying tools, for instance by scaling the length, width 
and thickness of the beam using  Mesh tools->Scale... or changing the applied load and/or elastic 
constants by right clicking to edit the appropriate item in the outline tree.

2.3  Creating
This  section  describes  in  turn  each  of  the  tools  for  creating  a  mesh.  Tools  for  modifying  it  are 
described in Section 2.4

2.3.1  Quick element

If you're making a simple orthogonal model or want to do a quick test on some feature in LISA, use the 
Mesh tools->Create->Quick square or and the Mesh tools->Create->Quick cube or  

They can be used as building blocks for a model by scaling, re-positioning and refining.

2.3.2  New node and New element

Use the Mesh tools->Create->Node... or 

if you would like to lay-out the nodes like this...

....in order to create the elements by clicking the nodes using  

 Mesh tools->Create->Element... or  .

The order in which the nodes are clicked will affect the direction in which 
element  subdivisions  take  effect  when  using  the  editing  tools.  So  be 
consistent  in  how  you  are  clicking  the  nodes.  For  example,  you  can 
choose to click the nodes by going counter-clockwise starting at the lower 
left corner.

2.3.3  Insert node between

Select  two  nodes  then  use  the  Mesh  tools->Insert  node  between to 
create a node mid-distance from both nodes. This is useful when laying out 
nodes for a coarse mesh.
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2.3.4  Templates

The Mesh tools->Templates... is used  primarily during the 
lay-out of a coarse two dimensional mesh.

For example, in this mesh (left) there are two nodes, each 
lying on an element edge.  This mismatch  means that there 
is no connection between the adjacent elements. Using the 
templates the larger  element  can be split  up into smaller 
elements so that there is now a node-to-node connection.

While easy to use for two dimensional meshes, it is not  practical to use for three dimensional meshes.

This tool is indispensable for laying out a coarse mesh and its use will be illustrated in the step-by-step 
modeling tutorials of Chapter 4.

2.3.5  Curve generator

The Mesh tools->Automesher 2D... is a two dimensional automesher that will mesh any area in the 
XY plane formed by plane or line elements.

The Mesh tools->Create->Curve generator... can be used to create these line element boundaries. 

The types of line element boundary that can be created are a straight line, arc, 
circle, ellipse and parabola. It is not likely that you will use the curve generator 
to create straight lines as there are other ways to create them such as using 
the Mesh tools->Create->Element....
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Your most common use of the curve generator will be to create arcs and circles.

Arcs can be created using either the center, start and end points or by specifying the start, end and 
any point lying on the arc.

You may also create a parabola, but it's not often that 
you will need one.

2.3.6  Polyline

The Mesh tools->Create->Polyline...  tool is used to create continuous straight lines. It is similar to 
the  curve  generator  tool  in  that  it  also  creates  line  element  boundaries  for  use  with  the  two 
dimensional automesher.  

There are two ways to use this tool. The first is to 
click  continually  in  the  graphics  display  area  to 
create a line element boundary. Since the clicking 
is  arbitrary  the  nodes  will  not  be  accurately 
positioned. If you need accuracy, select the nodes 
then right  click  on the selected node and select 
Node coordinates and type in the correct value.

The second way is to specify  either the absolute 
co-ordinate positions for the end points of the line 
or  distance of  the end point  relative to the start 
point of the current line segment.
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2.3.7  Automesh 2D

The Mesh tools->Automesh 2D... is used to fill an area bounded 
by  line  elements  or  formed  by  plane  elements  with  either 
quadrilateral or triangle or a mix of both element shapes. After a 
successful  automesh the original elements will  no longer  exist. 
The automesher can create elements only in the XY plane. If you 
create  the  original  elements  in  three  dimensional  space,  the 
automesher will project them onto the XY plane and mesh only 
the projected area. If the projection on the XY plane appears as a 
straight line, the automesher will fail. The automesher runs as a 
separate process in another window.

The  automesher  will  fill  the 
entire  bounding  area  with 
elements  including  any 
holes.  You will  then have to 
delete manually the elements 
in the hole areas.

Depending on how you created and edited your model, you may have places where two parts of the 
bounding lines appear to be joined but are not. For example these two line 
elements look as though they are connected with each other, but on displaying their node numbers, it's 
clear that there are actually two overlapping nodes .  This  means 
the line elements are not connected  to each other.

If  there are any unconnected line elements the automesher will  fail.  Therefore, before running the 
automesher,  always  use  the  editing  tool  Mesh  tools->Merge  nearby  nodes... to  replace  any 
overlapping  nodes  with  a  shared  node,  thereby  connecting  all 
elements. 

If the automesher default values make a mesh with only a few large elements, re-run the automesher 
using a smaller value for the Maximum element size. If you don't know what maximum size value to 
specify, use the tape measure tool to measure the smallest line segment. It will give a dynamic 
read-out as you click and drag from one node to another. 

By default, quadrilateral elements are set to be the dominant element of the mesh. If you have a good 
reason for using triangle elements, you may uncheck Quad dominant. 

You can also use 2nd order elements with midside nodes by checking Quadratic elements.
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2.3.8  Plates

In  Mesh tools->Create-> there are  templates for creating simple shapes like a circular, square and 
octagonal plate with or without holes.  These templates are simple to use and are self-explanatory.

These shapes can be extruded or revolved to generate three dimensional solids.
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2.4  Editing

2.4.1  Move

The Mesh tools->Create->Move/copy... is used to reposition or duplicate nodes or elements in the X, 
Y or Z axis directions.

Note the copy check box. If this is ticked, the selection is 
both moved and duplicated. Bear in mind that the copies 
are not connected to each other. Use the Mesh Tools-
>Merge nearby nodes... to connect them.

2.4.2  Rotate

The Mesh tools->Create->Rotate/copy... is used to rotationally reposition nodes or elements.

With the copy option selected nodes and elements can be 
duplicated.

2.4.3  Mirror

The Mesh tools->Create->Mirror/copy... is used to reposition nodes or elements by mirroring.

When the Copy option is selected, it can be used to mirror meshes.

At the mirror joint the elements will not be connected so you will 
have to use the Mesh tools->Merge nearby nodes... to make it a 
continuous mesh.

2.4.4  Scale

The  Mesh  tools->Create->Scale...  is  used  to  re-size  either  the 
entire mesh or the selected items. If you're not re-sizing the entire 
mesh but only a selected portion of the model, you should move it 
so that it is centered at the origin.  This is because  scaling is done 
relative to the origin.
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2.4.5  Hollow

The Mesh tools->Hollow is used to convert a solid mesh into a shell 
mesh.

2.4.6  Fit to sphere/cylinder/cone

The Mesh tools->Fit to sphere/cylinder/cone... is used to smooth 
circular features that look faceted after they have been refined.

2.4.7  Merge nearby nodes

The Mesh tools->Merge nearby nodes will ensure that the elements are connected node-to-node by 
replacing overlapping nodes with a single shared node. Meshing operations such as  Mesh tools-
>Refine->Custom... or Mesh tools->Templates... or Mesh tools->Move/Rotate with the Copy option 
will create meshes that are not connected. Separate files assembled using File->Load into model... 
will also not be automatically connected to each other at the mating surface.

The View->Open cracks tool will expose unconnected elements. It shrinks elements slightly to open 
up any existing gap between adjacent faces of unconnected elements. 

To eliminate these gaps use the Mesh tools->Merge nearby nodes to delete overlapping nodes. You 
have to specify a radial distance within which two or more nodes will be replaced by a single node. Too 
small a value and all the overlapped nodes will not be eliminated. Too large  a  value  and  you 
risk collapsing elements as they lose a node. Use the Tape Measure tool to  determine  the 
smallest distance between two nodes in your mesh,  then use a value smaller than this so that 
elements don't collapse. You will notice the change in node numbers in the status bar after using this 
command. 

Always use this tool after all meshing has been completed and before applying loads and constraints.
Then use the View->Open Cracks to confirm that you got it right.

2.4.8  Delete unused nodes

The Mesh tools->Delete unused nodes will remove any 
node not belonging to an element.

If you use Edit->Delete elements and retains nodes, 
the nodes will be left behind. If you can't see them, 
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activate the node select mode 

2.4.9  Invert

If  the  solver  fails  with  a  message  about  incorrect  element  topology,  you  can  select  the  affected 
elements and use the Mesh tools->Invert to fix their topology.

2.5  Converting a two dimensional mesh into a three dimensional mesh
The following tools work only in the face selection mode

2.5.1  Extrude

Select the faces then use Mesh tools->Extrude... to create a 3D solid 
mesh.

2.5.2  Revolve

Select the faces then use Mesh tools->Revolve... to create 
a 3D solid mesh.

If there are nodes at radius = 0, badly shaped elements will 
be  created  there.   To  fix  this  problem first  run  the  Mesh 
tools->  Merge  nearby  nodes...  then  use  Mesh->Correct 
collapsed elements.

2.5.3  Loft

This tool is useful for creating tapered solids. For example 
first create a two dimensional mesh, next  copy/move it to a 
new location  and then scale  it  to  give you a second two 
dimensional  mesh that  is  similar  in  shape but  different  in 
size. The Mesh tools->Loft... can then be used to create a 
3D solid mesh between the two meshes.
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2.6  Refinement
The results of a finite element analysis are reported at the element nodes. If you were solving for the 
stress, temperature, magnetic field, etc. and these field values were the same over a large area, it  
would not matter whether you used more or fewer elements over that area – the results would be the 
same.  However, if these values were to change rapidly over an area and you used very few elements 
over that area, the mesh will not accurately capture the change in value that is occurring. 

To illustrate the need for refinement when a value changes greatly, consider the geometry of a circle 
created by using straight lines.

If very few lines are used, it will not represent the circle very well.

If more lines are used, it will represent the circle more closely.

Likewise, in finite element analysis to represent a field value that is changing rapidly you have to use 
more elements over that region.  To achieve this use the following mesh refinement tools.

2.6.1  Refine x2

Mesh tools->Refine->x2 replaces every element with two elements 
along each edge.

Excellent for refining a coarse mesh, provided the model size doesn't 
get  much  past  100,000  nodes.  For  hexahedron  elements,  this 
increases the number of elements 8-fold so if  the mesh is already 

large it will probably run out of memory when solved.

2.6.2  Refine Custom

Mesh tools->Refine->Custom... is used to subdivide elements by specifying 
the  number  of  subdivisions  along  three  dimensions.  If  no  elements  are 
selected, it subdivides the entire mesh.
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2.6.3  Quad local refinement x2

Local mesh refinement is useful for adding more elements to only those areas with a rapid change in 
field value, while leaving fewer elements in areas where the field changes more slowly.  This is 
effective in not bloating the size of the model which can happen when using  Mesh tools->Refine->x2 

Mesh tools->Refine->Quad local refinement x2...  is 
used  to  refine  shell  elements  by  subdividing  the 
selected faces into two elements along each direction, 
then merging the subdivided elements with the rest of 
the mesh so that the elements are connected node-to 
node. 

2.6.4  Quad local refinement x3

Similar to the quad local refinement x2, the Mesh tools->Refine->Quad local 
refinement  x3...  refines  the  selected  faces  by  subdividing  it  into  three 
elements along each direction.

2.6.5  Change element shape

Results  can  converge  faster  by  changing  to 
higher  order  elements  using   Mesh  tools-
>Change element shape...

The choice of element shapes will be enabled 
or  disabled  according  to  the  element  shapes 
present, so you might have to repeat this step 
to get the final desired element.

To determine the areas that need mesh refinement you will first need to solve a coarse mesh and click 
the nodes in the solution for a read-out of the field value. If you find the field value is changing by a 
large amount over a small area, that tells you the area needs more elements.  
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You should note down the values in the corresponding areas of a coarse mesh and a refined mesh 
and calculate the % change in the results. If the % difference in the results of the coarse and refined 
mesh is very small, such as 3%, the results can be said to have converged and no gains in accuracy 
are to be achieved by further mesh refinement. If the % difference in the results is large -- for example 
20% – then further refinement is required.

To not have to reapply loads and constraints to a mesh that is to be refined, apply the loads and 
constraints to Named Selections in the coarse mesh rather than applying them to nodes directly.

You will get to practice using these tools in Chapter 4 where the creation of three complex geometries 
are explained step-by-step. 

The next chapter is a step-by-step walk through for each of the various analysis types that can be 
modeled in LISA.
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Chapter 3
3 Analysis Types

While the typical user does not  need an in-depth study of  the mathematics behind finite element 
analysis, you do need to understand the behavior of elements, in order to represent a given physical 
problem  correctly.  This  understanding  will  influence  your  choice  of  element  type,  element  size, 
element shape, constraints, loads, etc. 

The expected learning curve for new entrants into finite element analysis will  be the same as the 
experiences of other analysts gone before, as shown below :

 

The finite element method uses a mathematical formulation of physical theory to represent physical 
behavior. Assumptions and limitations of theory (like beam theory, plate theory, Fourier theory, etc.) 
must not be violated by what we ask the software to do.  A competent user must have a good physical 
grasp of the problem so that errors in computed results can be detected and a judgment made as to 
whether the results are to be trusted or not. 
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Finite element analysis is not like CAD (computer aided design) software where you simply create a 
geometry and take a print-out. Instead, it follows the law of 'Garbage in, Garbage out'. Your choice of 
element  type,  mesh layout,  correctness  of  applied  constraints  will  directly  affect  the  stability  and 
accuracy of the solution. 

We recommend to beginners that you confine your models to text-book problems with known solutions 
rather than attempting real  world problems with unverifiable solutions.  When you get  to  the point 
where you're solving real world problems, never accept the results at face value. Rather, validate them 
by comparing the results to hand calculations,  experimental  observations or  knowledge from past 
experience.

This chapter contains tutorials to initiate you into using LISA's basic analysis capabilities.  Advanced 
capabilities  like  modeling  thermal-stress  problems,  composite  materials,  cyclic  symmetry,  coupled 
nodes, mixed material and mixed element models are described in the Tutorials and Reference Guide.

LISA works only with numerical quantities.  It does not differentiate between N/m2 and N/mm2. This 
means that you must use a consistent system of units throughout your analysis. For example, if you're 
using millimeter for length, then Young's modulus should be in N/mm2 and not N/m2. If you're using 
N/m2 for Young's modulus then use N for force, not kN.  

Not all types of elements can be used for all types of analysis. The  Tutorials and 
Reference Guide lists the elements that are available for use in each type of 
analysis. When creating elements, if you see an N/A ('not applicable') next to the 
type of element, it means it can't be used to solve that type of analysis. However, 
you can use non-applicable elements as construction tools provided you change 
them using Mesh tools->Change element shape... , or delete them.

The outline tree presents all the information you need about your model and 
allows you to perform various actions on the model itself. You will always 
begin at the top, changing the analysis type if you do not want the default,  
3D static analysis. 

Items that appear in red indicate missing or erroneous information, so right 
click them for a What's wrong? clue. 

As  you  create  the  mesh,  information  will  be  added  to  Components  &  Materials and  Named 
Selections.  Try  to  apply  your  loads  and  constraints  to  element  faces rather  than  nodes.  Mesh 
refinements  will  automatically  transfer  element  face loads  and  constraints  to  the  newly  created 
elements, whereas loads and constraints applied to nodes are not automatically transferred to the new 
elements.

The constraints and loads that you apply will  be listed in the  Loads & Constraints section. After 
solving the model the field values will be listed below Solution.
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3.1  Static analysis of a pressurized cylinder

A cylinder of 2m radius, 10m length, 0.2m thickness, Young's modulus 15000 N/m2 and Poisson ratio 
0.285 will be analyzed to determine its hoop stress caused by an internal pressure of 100N/m2. 

From shell theory, the circumferential or hoop stress for a thin cylinder of constant radius and uniform 
internal pressure is given by :

σ = (pressure × radius) / thickness

σ = (100 × 2) / 0.2

σ = 1000 N/m2

Step 1

Check that the default analysis type is Static 3D.

Step 2

Mesh tools->Create->Create curve generator... select 
X1 2
Y1 0
Z1 0
X2 2
Y2 0
Z2 10
Number of nodes 12

Use the Fit to screen to display the elements.
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Step 3

Due to the axial symmetry, only one quadrant will be modeled. 

Activate select faces

Drag to select all the elements.

Mesh tools->Revolve...
Axis of revolution +Z
Angle 90
Number of subdivisions 8

Step 4

Right click,  Assign new material
Geometric tab 
select plate/shell/membrane
Thickness 0.2

Mechanical tab
select Isotropic
Young's modulus 200E9
Poisson's ratio 0.285
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Step 5

Right click the X arrowhead to view the YZ plane parallel to the screen. 

Activate select faces, activate show element surfaces, and activate show shell thickness 

Because of the mirror symmetry only one quadrant of the cylinder has been modeled. At the planes of 
mirror symmetry, the nodes must be constrained so that they do not move out of the plane.  Also, no 
bending must occur in that plane of symmetry.

To enforce mirror symmetry at the edge in the YZ 
plane, drag to select the thickness of the shell.

Right click, New displacement
        X 0

While the shell thickness is still selected, activate select nodes and toggle off the show element 
surfaces

Right click, On selected nodes->New rotz
Value 0

Right click the Y arrowhead to view the ZX plane parallel to the screen. 
Activate show element surfaces and activate select faces

To enforce mirror symmetry at the edge in the ZX plane, drag to select the thickness 
of the shell.

Right click, New displacement
         Y 0

While the shell thickness is still selected, activate select nodes and toggle off the 
show element surfaces

Right click, On selected nodes->New rotz
Value 0
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Activate select faces, activate show element surfaces, and activate show shell thickness 

Click the Z arrowhead to view the XY plane parallel to the screen.

To eliminate rigid body translation motion along the Z axis drag to select the 
shell thickness in the XY plane.

Right click, New displacement
        Z 0

Step 6

Activate select faces

Drag to select the entire mesh

Right click, New pressure
Normal -100
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Step 7

Click to solve the model. 

The results are listed in the outline tree below Solution. Click to view the 
hoop stress. 

The first thing to check is the deformation. Errors in the applied constraints or loads can show up in 
the deformation shape.

Click the Z arrowhead to view the XY plane parallel to the screen. 

Click the View deformed tool-button and accept the default values.

Click the Undeformed mesh on/off tool-button to superimpose the undeformed geometry onto 
the deformed geometry.

Observe  that  the  nodes  in  the  YZ  and  ZX  plane 
remain in these planes and no bending has occurred, 
this indicates that the constraints applied to enforce 
symmetry  are  working.   The  fact  the  deformation 
expands outward radially  indicates  that  the  internal 
pressure has been correctly applied.

The computed hoop stress is only 0.48% different 
from the hand calculations.  This  is close enough 
not to need further mesh refinement.

36



3.2  Thermal analysis of a plate being cooled
A plate of cross-section thickness 0.1m at an initial temperature of 250°C is suddenly immersed in an 
oil bath of temperature 50°C. The material has a thermal conductivity of 204W/m/°C, heat transfer 
coefficient  of  80W/m2/°C,  density 2707 kg/m3  and a specific  heat  of  896 J/kg/°C.  It  is  required to 
determine the time taken for the slab to cool to a temperature of 200*C.

For Biot numbers less than 0.1, the temperature anywhere in the cross-section will be the same with 
time. A quick calculation shows that this is true.

Bi = hL/k = (80)(0.1)/(204) = 0.0392

The 4 node quadrilateral element interpolates temperature linearly, and is able to represent unsteady 
states of heat transfer so this element will be selected for the model.

We need to have a rough estimate of the time required to reach a temperature of 200*C. In this case, 
from classical heat transfer theory the following lumped analysis heat transfer formula can be used.

(T(t)-Ta)/(To-Ta) = e-(mt)

Ta = temperature of oil bath

To = initial temperature

where m =  h/ ρ Cp(L/2)

h = heat transfer coefficient

ρ = density

Cp = specific heat

L = thickness

m = 80/[(2707)(896)(0.1/2)]

m = 1/1515.92 s-1

(200 - 50) / (250 - 50) = e(-t/1515.92)

t = ln (4) X 1515.92

t = 436 s

Step 1

Right click, Edit. Select 3D, then select Thermal Transient
Number of time steps 450
Time step 1

The total duration of this analysis is  450 × 1sec = 450 sec or 7 1/2 minutes.

The  Decimation number of time steps  is  a way to reduce the memory required for  storing the 
solution. This model is simple enough that we can use the default  All. For larger models you could 
choose to save every 10th or 100th solution of a transient analysis,  thereby significantly reducing 
memory requirements.
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A slider is displayed to show the duration of the analysis, which in this case is 450 seconds. It will be 
utilized when viewing the results.

Step 2

Click the Z arrowhead to view the XY plane parallel to the screen. 

Mesh tools->Create->Node... 

X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node make sure you've activated the node select mode 

Add more nodes using the following coordinates.
(0.1,0,0)
(0.1,0.2,0)
(0,0.2,0)

Use the Fit to screen to display the nodes.
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Step 3

Mesh tools -> Create > Element...  Select and click the four nodes. 

The order of nodes will affect the way the element gets subdivided in a following step. 
So, to keep the order the same, start at the lower left corner and go counter-
clockwise. 

Step 4

Right click, select Assign new material
Geometric tab
Plate/shell/membrane select
Thickness 1

Mechanical tab
Isotropic select
Density 2707

Thermal tab
Isotropic select
Thermal conductivity 204
Specific heat 896

Step 5

Activate select faces

Select the element. 

Mesh tools->Refine->Custom...
R 4
S 8
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Step 6

Activate select nodes

Convective heat transfer takes place along the surface of the entire plate. For the FE 
model, this will be the left and right edges. Click and drag the mouse over the nodes 
of the left edge so that they become selected. Hold the Ctrl key down and repeat it 
for the nodes on the right edge.

Activate select faces

The element edges are now selected.

Right click  then select New convection

Ambient temperature 50
Heat transfer coefficient 80

Step 7

Activate select faces

Drag a rectangle to select the entire mesh.

Right click and select New temperature, type 250 in the text-box.
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Step 8

Click to solve the model.  The results are listed in the outline tree below Solution.  

Click 

Drag the slider to view the temperature changes with time.

If you click a node the temperature profile of that node will be displayed in the timeline.

From the results we see that it  takes about 
440  seconds  to  reach  the  temperature  of 
200°C.

For transient thermal models if your results show a strange oscillation of temperatures every other 
time-step, use a smaller time-step value and refine the mesh further. If the solver stops with an out of 
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memory error message use decimation as explained in the accompanying Tutorials and Reference 
Guide.

3.3  Modal vibration of a cantilever beam

A cantilever beam of length 1.2m, cross-section 0.2m × 0.05m, Young's modulus 200×109 Pa, Poisson 
ratio  0.3  and  density  7860  kg/m3.  The  lowest  natural  frequency  of  this  beam  is  required  to  be 
determined.

For thin beams, the following analytical equation is used to calculate the first natural frequency :

f = (3.52/2π)[(k / 3 × M)]1/2

f = frequency

M = mass

M = density × volume

M = 7860 × 1.2 × 0.05 × 0.2

M = 94.32 kg

k = spring stiffness

k = 3×E×I / L3

I = moment of inertia of the cross-section.

E = Young's modulus

L = beam length

I = (1/12)(bh3)

I = (1/12) (0.2 x 0.053)

I = 2.083×10-6 m4

k = (3 × 200×109 × 2.083×10-6) / 1.23

k = 723.379×103 N/m

f = (3.52/2 × 3.14) [(723.379×103/ 3 × 94.32)]1/2

f = 28.32 Hz

Step 1

Right click, Edit, Select 2D, then select Modal Vibration 2D Plane and Truss. 
Number of modes 3
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Step 2

Mesh tools->Create->Node... 
X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node make sure you've in the node select mode 

Click the Z arrowhead to view the XY plane parallel to the screen. 

Add more nodes using the following coordinates.
(1.2,0,0)
(1.2,0.05,0)
(0,0.05,0)

Use the Fit to screen to display the nodes.

Step 3

Mesh tools -> Create -> Element... Select and click  the four  nodes.  The order  of 
the clicked nodes will affect the orientation of the mesh refinement that will be done in the next step. In 
this tutorial the element is formed using the node order 1,2,3,4.
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Step 4

Right click,  Assign new material
Geometric tab select plate/shell/membrane
Thickness 0.2

Mechanical tab
Isotropic select
Young's modulus 200E09
Poisson's ratio 0.3
Density 7860

Step 5

Mesh tools->Refine->Custom...
Number of subdivisions
R 16
S 1

Step 6

Elements with a mid-side node (quadratic) are more flexible in bending problems. These four node 
quadrilaterals  will  be changed into eight  node quadrilaterals using  Mesh tools->Change element 
shape..., select quad8 

Step 7

Activate select nodes

Drag  to  select  the  nodes  at 
the left edge.
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Activate select faces

The element  face at  the  left  is 
now selected.

Right click  then select New fixed support

Step 8

Click to solve the model. 

The results are listed in the outline tree below Solution. Click

Click the animation tool-button to view the mode shape. For this problem, the lowest mode shape 
is expected to vibrate back and forth in bending.

The actual displacement numbers of a modal analysis have no meaning, 
they  simply  serve  the  purpose  of  providing  a  visualization  of  the 
deflection.

The frequency for the lowest mode matches the hand calculation.
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3.4  Dynamic response of a crane frame

A dynamic response analysis is difficult to estimate values for by simple hand calculations. This tutorial 
will simply illustrate the dynamic response analysis work-flow of a crane's truss framework.

Step 1

Right click, Edit. Select 2D, then select Dynamic Response
Number of time steps 100
Time step 0.005

The  Decimation number of time steps  is  a way to reduce the memory required for  storing the 
solution. This model is simple enough that we can use the default  All. For large models you could 
choose to save every 10th or 100th time step of the solution, reducing memory requirements to a 
fraction of the default All.

Step 2

Mesh tools->Create->Create curve generator... select 
X1 0
Y1 0
Z1 0
X2 20
Y2 0
Z2 0
Number of nodes 5

Click the Z arrowhead to view the XY plane parallel to the screen. 

Use the Fit to screen to display the whole mesh.

Activate select elements

Drag  to  select  all  the  elements.  Right  click  on  the  selected 
elements  and  select  Element  properties.  Select  the  check-box 
next to  Truss to convert these elements from beam elements to 
truss.

Step 3
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Select the entire mesh.

Mesh tools->Move/copy...
Y 5
Copy select

Step 4

Activate select nodes

Mesh  tools->Create->Element...  Select and  click  the nodes  to  form the following 
pattern.

1,6
2,7
3,8
4,9
5,10
6,2
7,3
8,4
9,5

Step 5

Right click,  Assign new material
Geometric tab
General section select
Cross-sectional area 0.0225

Mechanical tab
Isotropic select
Young's modulus 200E09
Poisson's ratio 0.3
Density 7860

Step 6
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Activate select nodes

Select  these two nodes.  Hold the  Ctrl key down while  selecting the 
second node so as not to deselect the first node. 

 
Right click then select New displacement, select Y, accept the default 0 value.

Select this node. 

 
Right  click then select  New displacement, select X, accept the default 0 value.

Step 7

Select this node. 

Right click then select New force
Y
Table select

0,0
0.01,-1
0.49,-1
0.5,0

Step 10
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Click to solve the model. 

The results are listed in the outline tree below Solution. 

Click the play/pause button in the timeline to view the dynamic response of the structure. 

Modal response analysis does essentially the same thing as dynamic response analysis but should 
only be used for very small models (<1000 nodes) as it may run too slowly or run out of memory. The 
following elements - beam, wedge, pyramid, quadratic  tetrahedrons and quadratic hexahedrons can 
be used for modal response. These element types are not available for use with dynamic response 
analysis.
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3.5  Magnetostatic analysis of a current carrying wire

The magnetic  field  around  a  single  copper  wire  carrying  a  current  will  be  modeled.  The wire  is 
perpendicular to the screen with the current flowing outward. The wire is of diameter 0.025 m and the 
current 30 A.

B = μ × I / (2π R)

B = magnetic field

μ =  permeability constant

μ = 1.26×10-6Tm/A

R =  radius

The magnetic field at a radial distance of 0.05m is required to be determined

BR = 1.26×10-6 × 30 / (2 × 3.14 × 0.05) = 0.12 mT

Step 1

Right click, Edit. Select 2D, then select Magnetostatic 2D
Permeability of free space 1.2566E-06

Step 2

The wire cross-section and the air surrounding the wire will be 
meshed using a template.

Mesh tools->Create->Circular plate 
Ro 0.1
Quadrants select all
Concentric nodes select

Click the Z arrowhead to view the XY plane parallel to the screen. 
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Step 3

Right click, Assign new material
Electromagnetic tab
Magnetic permeability 1

Step 4

Activate select faces

Drag to select the surfaces of the elements at the center within a radius 
0.0125. These elements belong to the wire.

right click, New current type a value of 30 in the 
text-box.

Step 5

Activate select nodes

Drag to select all the nodes.

Edit->Circle selection

Hold the Ctrl key down and also the Shift key. 
Then click the center and drag to just before the 
nodes of the outer diameter.

The Ctrl key has the effect of preventing nodes 
that  are  already  selected  from  becoming 
deselected. And the  Shift key will  prevent the 
center node from being dragged by the mouse. 
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Activate select faces

The node selection turns into a selection of the outer-diameter faces of the 
elements.

Right click on select New magnetic vector potential, accept the default 0 value.

Step 6

Click to solve the model. 

The results are listed in the outline tree below Solution. Click

Click node three which 
is  at  a radial  distance 
of 0.05. 

The  value  of  the 
magnetic  field  at  this 
distance  matches  the 
expected value.
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3.6  DC circuit analysis

The following circuit will be solved for the voltage drop across the resistances, and  the currents.

Current flowing through the 40Ω and 50Ω resistors 
is
12V/(40Ω+50Ω) = 0.13A

Current  flow  through  the  60Ω  resistor  is  
12V/60Ω = 0.2A

The  voltage  drop  across  the  40Ω  resistor  is 
0.13A×40Ω = 5.3V 

Voltage drop across the 50Ω resistor is 

0.13A×50Ω = 6.7V

Voltage drop across the 60Ω resistor is 12V

Step 1

Right click, Edit. Select 3D, then select DC Current Flow.

Step 2

Click the Z arrowhead to view the XY plane parallel to the screen. 

Click the Polyline tool and click to form the following two line 
elements.

Click the Close shape button to complete the model.
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Step 3

As each element has a different resistance, they need to be separate entities in the Components & 
Materials.

Activate select elements

Right click on the selected element and select Add elements to new 
component

Right click on the new component and 
select Assign new material. 
Electromagnetic tab
Extensive select
Resistance 40

Repeat this step for the second element.

Electromagnetic tab
Extensive select
Resistance 50

As there is only one element left in the Default under Components & Materials, right click to Assign 
a new material.

Electromagnetic tab
Extensive select
Resistance 60
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Step 4

Activate Select nodes

 
Right  click  on  this  selected  node  then  select 
Loads & constraints  -> New voltage type 0 in 
the text-box.

Right  click  on  this  selected  node  then  select  Loads  & 
constraints -> New voltage type 12 in the text-box.

A 12V voltage has now been applied to the circuit.

Step 5

Click to solve the model. 

The results are listed in the outline tree below Solution. 

Select one of the field values and then click 
a node for a read-out of that value.

The sign of a current indicates its direction. If it is +ve, the current 
is flowing in the direction in which you formed the element going 
from the first node of that element to the second node. If the value 
is -ve, current is flowing in the opposite direction from the second 
node to the first. 

For the currents use the to check the currents at the nodes instead of the graphics display 
of node averaged values. Nodal averaging can be misleading, for example the -0.2A in the 
60Ω resistor averaged with the 0.1333A in the 40ohm resistor gives a non-existent 0.03333A.

55



3.7  Electrostatic analysis of a capacitor

The electric field between a simple two plate capacitor will be modeled. The plates are 0.005 m apart 
with air in between, and a potential difference of 1.5V.

The expected electric field, E = potential difference / distance between plates 

E = 1.5 / 0.005 = 300 V/m

Step 1

Right click, Edit. Select 2D, then select Electrostatic 2D
Permittivity of free space 8.854E-12

Step 2

Click the Z arrowhead to view the XY plane parallel to the screen. 

Mesh tools->Create->Node... 
X 0
Y 0
Z 0

A red dot appears at the origin.

Add more nodes using the following coordinates.
(0.015,0,0)
(0.015,0.005,0)
(0,0.005,0)

Use the Fit to screen to display the nodes
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Step 3

In this tutorial the area between the two plates of the capacitor will be defined using two node line 
elements, and then the 2D automesher will then be used to fill the region with quadrilateral or triangle 
elements.

Mesh tools -> Create > Element...  Select and click the four nodes to form the area 
between the two plates. 

Step 4

Mesh tools->Automesh 2D...
Maximum element size 0.001
accept the rest of the defaults

Step 5

Right click,  Assign new material
Geometric tab
Thickness 1

Electromagnetic tab
Isotropic select
Relative permittivity 1
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Step 6

Activate Select nodes

Drag to select the nodes at the top. 

Activate select faces 

The element faces will become selected. Although 
they appear to be edges, in reality they are faces 
normal  to  the  screen  because  of  the  thickness 
dimension that is not displayed.

While the faces (edges) are selected, 
right  click  on  Loads  &  Constraints 
then click New voltage.   Type 1.5 in 
the text-box.

Activate Select nodes

Drag to select the nodes at the bottom.
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Activate select faces 

The element edges will become selected.

While the edges (faces) are selected, 
right  click  on  Loads  &  Constraints 
then  click  New  voltage.  Accept  the 
default 0 value.

Step 7

Click to solve the model. 

The results are listed in the outline tree below Solution. Click 

This matches the expected value of 
300 V/m.
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3.8  Acoustic analysis of an organ pipe
We will predict the musical note produced by an 8 ft (2.4384m) long 'open wood' organ pipe.  An actual 
pipe would be rectangular in section, but here we make only a 2D model.  The pipe will be 120 mm 
wide with a 30 mm mouth at one end where air is blown in, and an opening at the other end for the air 
to exit.  The wood is 10 mm thick.  

In acoustic analysis the air within the pipe needs to be meshed and not the pipe itself.  The mesh 
needs to include a large volume of the air in the room outside the pipe which is connected to the 
mouth  and the open end.   This  scheme allows  LISA to model  leakages and openings.   We are 
interested only in the resonant modes of the organ pipe, but LISA will also predict resonances in the 
air outside.  An important part of this case study, therefore, is to show how some understanding of the 
physics is required in order to interpret the results and identify the appropriate modes.

A rough calculation will be made for the expected frequency. 

An end correction factor must be added to the length of the pipe. This correction factor is equal to the 
width of the pipe. So the effective length of the pipe is 2.4384 + 0.12 = 2.5584

When 1/2 a wavelength fits into the pipe it will be of length 2 × 2.5584 = 5.1168

The  velocity  of  sound  in  air  at  18°C  is  342  m/sec,  so  the  expected  frequency  will  be 
velocity/wavelength = 342/5.1168 = 66.84 Hz.  

Step 1

Right click, Edit. Select 2D, then select Acoustic Cavity Modes 2D
Number of modes 20 

To ascertain the fundamental pitch we need to examine the results for a number of pitches.  We will  
also look at harmonics.

Step 2

Mesh tools->Create->Node... 
X 0
Y 0
Z 0

The node appears as a red dot at the origin.
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If you don't see the node make sure you've activated the node select mode 

Click the Z arrowhead to view the XY plane parallel to the screen. 

Add more nodes using the following coordinates.   Dimensions are in meters.
(2.4384,0,0)
(2.4384,0.12,0)
(0,0.12,0)

Use the Fit to screen to display the nodes.

Step 3

You will have to zoom-in to see the nodes.  Drag to select the nodes on the left.

Mesh tools->Move/copy...
X -2.0
Copy select

Select the same nodes 
Mesh tools->Move/copy...
X -0.01
Copy select

You will have to zoom-in to see these nodes.

Drag to select the nodes on the very right.

Mesh tools->Move/copy...
X 2.7
Copy select
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Step 4

Drag to select the following nodes

Mesh tools->Move/copy...
Y 0.8
Copy select

Drag to select the following nodes

Mesh tools->Move/copy...
Y 0.01
Copy select

These nodes will be too close together so you will have to zoom-in to see 
them.

Drag to select the following nodes

Mesh tools->Move/copy...
Y -0.6
Copy select
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Drag to select the same nodes.

Mesh tools->Move/copy...
Y -0.01
Copy select

A zoomed-in view shows these nodes.

Step 5

Activate select nodes

Mesh  tools->Create->Element...  Select and click four nodes to form the following 
pattern  of  quadrilaterals.  The  order  of  the  clicked  nodes  will  affect  the  orientation  of  the  mesh 
refinement that will be done in the next step. In this tutorial the elements have been formed by going 
counter-clockwise starting with the node at the lower left corner.

23,24,29,28
28,29,7,5
5,7,8,6
6,8,19,18
18,19,14,13
24,21,26,29
19,17,12,14
17,16,11,12
1,2,3,4
21,22,27,26
22,25,30,27
27,30,9,2
2,9,10,3
3,10,20,16
16,20,15,11
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The zoomed-in view shows the white areas where 
no elements are present, representing 0.01 m pipe 
thickness.

Step 6

Right click and select Assign new material
Mechanical tab
Isotropic select
Speed of sound 342

Step 7

Activate select elements

Select the element in the center.  This will be 
the air in the organ pipe.

Right click select New component

64



Step 8

Right click and Rename it to Pipe air.  Notice how LISA assigns a 
different color to it.  You can right-click again to select a Color of your 
choosing.

Right click and Rename it to Room air.

Step 9   

We now refine the mesh through several stages.

Click on the Pipe_air component to select its element.

Mesh tools->Refine->Custom...
R 120
S 2

If you find the subdivisions are in the wrong direction Ctrl+Z to undo and use 2 for R and 120 for S.

While still in the select elements mode, select the larger room air elements. Hold the Ctrl key down so 
that the first selected element does not become deselected when you click the second element.

Mesh tools->Refine->Custom...

R 20
S 3
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Select this element 

Mesh tools->Refine->Custom...

R 20
S 1

Select this element.

Mesh tools->Refine->Custom...

R 20
S 2

Select these four elements.
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Mesh tools->Refine->Custom...
R 20
S 1

Select these two elements 
Mesh tools->Refine->Custom...
R 1
S 3

Select this column of elements just outside the open end of the pipe.  We need refinement here 
because some air immediately outside the pipe will also vibrate.

Mesh tools->Refine->Custom...
R 4
S 1
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Now zoom in on the left hand end of the pipe.  Activate select faces

Select these three elements.

Mesh tools->Refine->Custom... 

R 4
S 1

That completes the refinement.  Your model should now look like this:

Step 10   

This is a good stage to connect up all the elements.  (If you  select  View->Open Cracks,  you  will 
see many gaps.)    Use the tape measure tool-button to  confirm  that  the  smallest  distance 
between the nodes is 0.01. Use the tape measure tool by clicking and dragging from one node to 
another. Right click to exit the tape measure tool. Then, select  Mesh Tools->Merge nearby nodes 
and type a value of 0.005.  Check again with View->Open Cracks.
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Step 11

The air in the pipe is currently connected to the air in the room only at its open end. The end with the 
mouth now needs to be connected to the air in the room.  The mouth is open 0.03 m.

 

 

Zoom-in  to view the left end of the pipe air elements.   Activate 
select  nodes then  select  these  four  nodes.   Right  click  on  the 
selected nodes, then select Node coordinates and change X to 0.015.

Select the four nodes to the right of the previously selected nodes and 
then the X to 0.03.
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Activate select nodes

To connect the air in the pipe with the air in the 
room at the lip use the  Mesh tools -> Create > 
Element..  Select and  click  the 
nodes to create the following two quadrilaterals.

Step 12   

The mesh needs to be refined just outside the mouth.  Any localized mesh refinement must produce 
only quad4 elements that correctly connect with the adjacent elements node-to-node, as nodes cannot 
be connected to element edges. 

Activate select faces 

Select these three elements. 

Mesh tools->Refine->Custom...
R 1
S 3

View->Open  Cracks will  show that  this 
operation  has  left  the  newly  created 
elements disconnected from the adjacent 
elements of the existing mesh.
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Activate select nodes

Select these two nodes.  
Mesh tools -> Insert node between

Now click the new node to select it.
Mesh tools -> Move/Copy...
Copy selected
Y 0.02

Activate select faces

The two nodes will be hidden.

Select  the  element  with  the  two  new 
nodes in the middle and delete it.

Activate select nodes

The two nodes will be displayed.
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Mesh tools ->Create Element... select 

Click  the  nodes  to  form  the  four  quadrilateral 
elements shown filling the area left behind by the 
deleted element.    

Likewise, delete this element on the other side of the lip. 

And again, fill the space with quadrilateral elements.

Check with View->Open Cracks 
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Step 13  

The mesh building is now complete so click to solve the model.   

The modal frequencies are listed in the outline tree below Solution.  Click the nodes for a read-out of 
the field value there. 

The subtlety in this case study is in interpreting the results.  From the 20 calculated modes we want to 
pick out the fundamental pitch of the pipe itself. Click through the various modes and observe that 
most show red, yellow and blue patches for the room air elements.

The 5th mode at 66.56 Hz is different because the ‘room’ is almost constant color (blue). Zoom in on 
the pipe, and notice that the maximum pressure value of the pipe air elements is 2.391, much higher 
than for any of the other modes.  This identifies mode 5 as the fundamental pitch of the pipe organ. 
Half a wavelength fits inside the pipe. The frequency matches the hand calculated value very well.
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Similarly Mode 12 at  133 Hz has an almost  constant  green color  in  the room and high,  variable 
pressure in the pipe.  This is the first harmonic at almost exactly twice the frequency, sounding one 
octave higher.  A full wavelength fits inside the pipe. 

 Mode 20 at almost 200 Hz is the third harmonic.
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Step 14  

As an exercise we will investigate the stability of the solution to a change in the size of the room.  

Select some nodes in the room to the right of the pipe, and use Mesh tools -> Scale... type 1.5 to 
scale the Y-co-ordinate. This enlarges part of the room without disturbing the pipe. The precise nodes 
and scale value used do not matter, so try several variations.

Run the solver again and observe that all the room modes change in frequency, but the pipe-only 
modes vary hardly at all from about 66 Hz and 133 Hz. 

Step 15    

Finally, investigate the effect of closing the open end of 
the  pipe  by  selecting  these  four  elements  which  lie 
immediately  outside  the  open  end.  Press  the  delete 
key. This now isolates the air in the pipe from the air in 
the room at what was once the open end of the pipe.

Run the solver.  The fundamental frequency drops to 34 
Hz  (Mode 3),  almost  an  octave lower  than the open 
pipe,  a fact  well  known to organists.    The pipe now 
holds only one quarter wavelength – observe that the 
pressure at the mouth is almost that in the room.
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3.9  Buckling of a column

The eigenvalue buckling of a column with a fixed  end will be solved. The column has a length of 
100mm, a square cross-section of 10mm and Young's modulus 200000 N/mm2 .

The critical load for a fixed end Euler column is π2EI/(4L2)

E = Young's modulus

I = moment of inertia

I = 104/12 = 833.33mm4

L = length

Critical load = π2 200000 × 833.33 / (4×1002)= 41123.19

Step 1

Right click, Edit. Select 2D, then select Buckling 2D Beam.
Number of modes 3
Shift point 1

Step 2

Mesh tools->Create->Node... 

X 0
Y 0
Z 0

The node appears as a red dot at the origin.

If you don't see the node, make sure you've activated the node select mode 

Add another node using the following co-ordinate.
(0,100,0)

Use the Fit to screen to display the nodes.
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Step 3

Mesh tools -> Create > Element.. Select and click the two nodes. 

Step 4

Right click, select Assign new material
Geometric tab
General section select
2nd moment of area about W 833.33
Cross sectional area 100

Mechanical tab
Isotropic select
Young's modulus 200000

Step 5

Mesh tools->Refine->x2 or repeat four more times. 

To see the mesh refinement switch to the node select mode 

Step 6

Select this node then right click and select New force. In 
the Y textbox type -1.
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Step 7

Activate select nodes

Select the node at the bottom then change to face selection mode  

Now the bottom end face is selected.

Right click and select New fixed support

Step 8

Click to solve the model. 

The results are listed in the outline tree below Solution. 

Click the animation tool-button to view the buckling mode shape.

As the load used for the model was 1N, the load 
at  failure  is  1x41123.27=  41123.27  N,  which 
matches the hand calculated value.
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3.10  Fluid flow around a cylinder

A confined streamlined flow around a cylinder will  be analyzed for the flow potentials and velocity 
distributions around the cylinder. The inward flow velocity is 1 m/s . The ambient pressure is  1×105 Pa, 
density 1000 kg / m3 . 

Step 1

Right click, Edit. Select 2D, then select Fluid Potential Flow 2D 
Ambient pressure  1E05

Step 2

Mesh tools->Create->Create curve generator... select 

D1 8
D2 8

Click the Z arrowhead to view the XY plane parallel to the screen. 

Use the Fit to screen to display the elements.

Step 3

Mesh tools->Create->Node... 
X -20
Y 8
Z 0

If you don't see the node, make sure you've activated the node select mode 

Add more nodes using the following coordinates.
(20,8,0)
(20,-8,0)
(-20,-8,0)
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Step 4

Mesh tools -> Create > Element.. Select and click the four nodes to form the outer 
boundary.

Step 5

Mesh tools->Merge nearby nodes...
Distance tolerance 0.001

Mesh tools->Automesh 2D...
Maximum element size 1.5
Quad dominant select

Step 6

Edit->Circle selection

Drag to select the nodes inside of 
the 8 diameter.

Press the delete key.
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Step 7

Right click,  Assign new material
Geometric tab select plate/shell/membrane
Thickness 1

Mechanical tab
Isotropic select
Density 1000

Step 8

Activate select nodes 
 

Edit->Rectangle selection

Select the nodes on the right edge.

Right click then select 

On selected nodes->New velocitypotential
Value 0

Step 9

Drag to select the nodes on the left edge

Switch to select faces
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Right click then select New flow rate in the text-box type 1.

Step 10

Click to solve the model. 

The results are listed in the outline tree below Solution. Click

Click to visualize the flow.

That concludes our overview of the types of analysis which LISA can carry out.  Bear in mind that 
static analysis can generally be done using orthotropic or anisotropic materials such as wood or 
carbon fiber composites, as well as the more familiar isotropic materials.
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Chapter 4
4 Modeling Tutorials

This chapter contains three advanced examples of building a mesh in LISA. As you work through 
them, you will gain greater skill and confidence in using the individual meshing tools, and also develop 
a wider understanding of how to plan a model-building project.  Important strategies include starting 
with the most complicated features first, using component symmetry, saving intermediate stages under 
different file names in case you have to back-track, and running the program at intermediate stages 
(perhaps with dummy data) to check that the Solver will run.  Complex objects can be modeled as a 
number of separate components, in separate LISA  files, and assembled later by importing them into 
one final LISA file.

4.1  Tapers, rectangle and V shaped cut-outs
Step 1

Identify  the  most  difficult  features 
and model  them before  the easier 
features. 

For this part the V-cut out would be 
the first feature to model.

83



Step 2

Mesh tools->Create->Node...

X 0
Y 0
Z 0

Repeat for the following coordinates

0,0,20
0,3,20
0,3,40
0,0,40
0,0,60
0,13,60
0,13,43
0,25,43
0,25,38
0,11,31.5
0,25,23
0,25,18
0,13,18
0,13,0

Click to make view parallel to the screen.

Step 3

Nodes need to be located at precise locations for accomplishing the cut-outs of the other views not 
currently visible in this view.

Mesh tools->Create->Node...

0,0,49
0,13,49
0,13,11
0,0,11
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Step 4

This profile is simple enough to be composed of only quadrilateral elements. However, in order to do 
that, additional nodes need to be created so that complete quadrilaterals can be formed. Elements 
need to be connected node to node. If a node falls on an edge, there will be no connection and a gap 
or penetration will occur.

Select this node Mesh tools->Move/copy...
Y -8
Copy selected

Select these nodes Mesh tools->Move/copy...
Y -10
Copy selected

Step 5

Mesh tools->Create->Element...
quad4 shell

Click the nodes to form quadrilaterals. Do 
this going counter-clockwise starting from 
the lower left corner. This is only so that the 
particular template button shown in the next 
step works the same on your mesh.

Step 6

To make the element sizes about the same size as each other, use the Mesh tools->Templates...

Activate select faces 

Select all these faces. Hold the Ctrl key down to add to or remove from 
the faces that have already been selected.

Click this template.
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Select these faces.  

Then use this template.

Depending on the order in which you clicked the nodes to form the elements the above tool-button 
might or might not have worked for you. If you formed the elements as instructed in the previous step 
to go counter-clockwise starting the lower left corner it would have worked. If you formed the elements 
any other way you will have to experiment with the available template patterns to get the mesh looking 
the same.

Step 7

Activate select faces 

Select the entire mesh. 

Mesh tools->Extrude...
Direction +X
Thickness 35
Number of subdivisions 7

The number of subdivisions was chosen as 7 because we have to plan ahead for the 15 wide cut-out. 
By keeping each element 35/7=5 wide, it will be a simple matter of deleting three rows of elements 
(3x5 =15) to obtain the cut-out.

If your extruded mesh looks strange Ctrl+Z to undo, and click in an open area to deselect everything 
then try it again.
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Step 8

Activate Select elements

Hold  the  Ctrl key  down  and  select  the  following  elements.  
Then press the delete key.

Select the elements that were inside and delete them 
as well.

That completes one cut-out.

Step 9

Rotate the model into view and repeat the previous step to 
complete the second cut-out.

Step 10

We have to create the rectangular cut-out in the V-section, however, we forgot to plan ahead and 
place   the  nodes  in  position  to  make  deleting  the  elements  easy.  You  will  have  to  re-set  the 
coordinates of the relevant nodes now.

Activate select nodes 

Select these nodes as viewed by clicking the X arrowhead 

Right click on the selected nodes and select Node coordinates
  Y 20
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As some elements are disproportionately larger than the rest of the mesh, activate select elements

Select all these elements. Hold the Ctrl key down to add elements 
to the selection set, dynamically rotate and zoom-in to do this.

 Mesh tools->Templates...

With 3D templates it might take a few 
attempts before getting the right one.

You  can  always  Ctrl+Z to  undo  a 
wrong choice.

Again,  if  this  template  button  doesn't  split  the  elements  as 
depicted, Ctrl+Z to undo and experiment with of the other similar 
patterns to get the mesh looking the same.

Step 11

Activate select elements

Hold  the  Ctrl key  down  and  select  the  following  elements.  
Then press the delete key.

Deleting a single element creates a cut-out 5 wide, but the cut-out needs to be 10 wide. You have to 
move the nodes to get it to the right size for the cut-out.
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Step 12

Click the Z arrowhead to view the model parallel to the screen.

Activate select nodes 

Select these nodes. Select this node Mesh tools->Move/copy...
X -2.5
Copy deselected

Select these nodes. Select this node Mesh tools->Move/copy...
X 2.5
Copy deselected

Step 13

Activate select nodes 

Click the Z arrowhead to view the model parallel to the screen.

      Select all the nodes along this face Mesh tools->Rotate/copy...
Rotation about point
X 35
Y  0
Z  0

Specify rotation angles around X, Y, Z axis in degrees
      0

 0
 6
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      Select all the nodes along this face Mesh tools->Rotate/copy...
Rotation about point
X 0
Y  0
Z  0

Specify rotation angles around X, Y, Z axis in degrees
      0

 0
 -6

Step 14

As this is a coarse mesh use the  Mesh 
tools->Refine->x2 to refine the mesh 
further.
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4.2  Rib, counter-bore and rounds
Step 1

Identify  the  most  difficult  features  and 
model them before the easier features. 

In this model the holes and rounds are the 
most difficult, so these will be modeled first.

Step 2

You will use the mirror symmetry of the part to initially model some features which will be mirrored and  
then the rest of the model will be completed.

Click the Z arrowhead to view the model parallel to the screen.

Mesh tools->Create->Curve generator...

Center X 112
Center Y    32
Center Z       0
Start Point X 112
Start Point Y      0
Start Point Z       0
End Point X 144
End Point Y    32
End Point Z       0
Number of Nodes     6

Click OK to return to the curve generator dialog.  Notice that the data has been converted into a 
trigonometric expression for the curve.  Click OK.

View->Fit to window
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Step 3

Mesh tools->Create->Curve generator...

 

D1 30
D2 30

Click OK to exit the ellipse dialog but don't exit the curve generator dialog just yet. 
Change the X = 15*cos(p) into X =  112+ 15*cos(p) and the Y = 15*sin(p)  into Y = 32 +15*sin(p), this 
will   move the circle  up by 32 where we  would  like it  to  be positioned.  Change the  Number of 
elements to 16. Now, click OK to exit the curve generator dialog.

Step 4

Mesh tools->Create->Curve generator...

X1     0
Y1     0
Z1     0
X2 112
Y2     0
Z2     0
Number of nodes     6
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Step 5

Click this node to obtain its node number which you will need for 
the mirror command.

Select the entire mesh then Mesh tools->Mirror/Copy...
Mirror plane YZ plane
Mirror point
Node number 24
Copy selected
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Step 6

Mesh tools->Create->Curve generator...

D1 82
D2 82

Click OK to exit the ellipse dialog but don't exit the curve generator dialog. 
Change the  Y = 41*sin(p)  into Y= 192 +41*sin(p), this will  move the circle up by 192. Change the 
Number of elements to 32. Now, click OK to exit the curve generator dialog.

Repeat for:
D1 50
D2 50

Change the  Y = 25*sin(p)  into Y= 192 +25*sin(p) and  Number of elements to 16
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Repeat for:
D1 34
D2 34

Change the  Y = 17*sin(p)  into Y= 192 +17*sin(p) and  Number of elements to 16

Step 7

The joint of the boss and the rib complicates creating the rib due to the curvature of the boss. To 
isolate the region of the rib in contact with the boss, a small rectangle with one side curved will be 
created.

Select these two nodes. 

Mesh tools->Move/copy...
Y -10
Copy selected

Right click this node and select Node coordinates
Change the X coordinate to -12.0
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Right click this node and select Node coordinates
Change the X coordinate to 12.0

The reason for moving these nodes is because the width of the rib is 24.0.

Step 8

Select both nodes Mesh tools->Move/copy...
Y -92.121
Copy selected

This will be the bottom profile of the rib. 

Select these two nodes and use the Mesh tools-> Insert node between 

Repeat the command to get evenly spaced nodes as shown.

Step 9
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Mesh tools->Create->Curve generator...

Center X 112
Center Y    32
Center Z       0
Start Point X 144
Start Point Y     32
Start Point Z       0
End Point X 112
End Point Y    64
End Point Z       0
Number of Nodes     6

Repeat for:

Center X -112
Center Y    32
Center Z       0
Start Point X -112
Start Point Y     64
Start Point Z       0
End Point X -144
End Point Y    32
End Point Z       0
Number of Nodes     6

Step 10

Select these two nodes and use the Mesh tools-> 
Insert node between 
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Use this tool repeatedly to obtain this pattern. 

Step 11

Activate select elements

Drag to select the entire mesh. Edit->Delete elements and 
retain nodes

Activate select nodes 

What we have left are just the nodes. We will use these nodes to lay 
out a coarse mesh from which the rest of the mesh will be built.
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Step 12

Mesh tools->Create->Element...
quad4 shell

Click  the  nodes  to  form  quadrilaterals. 
Do this going counter-clockwise starting 
from the lower left corner. This is only so 
that the particular template button used 
in step 13 will  have the same result on 
your mesh. 

Don't  worry  about  the  lack  of 
symmetry in  the mesh lay-out,  it 
will  be  refined  in  the  end  and 
everything will be fine.
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Step 13

To make the elements about the same size as each other, use the Mesh tools->Templates...

Activate select faces 

Select all these faces. Hold the Ctrl key down to add to or remove 
from the faces that have already been selected.

  

Then use this template.

The action of the template depends on the order in which you clicked the nodes while creating it. So if 
it does not look the same as this, undo. Then try another to get it to look the same.

Repeat the template over the same selection. 
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Step 14

Activate select nodes 

Select these nodes and press the delete key.

Select these two nodes and use the Mesh tools-> Insert node between 

Repeat for the other side too.

Step 15

Mesh tools->Create->Element...
quad4 shell

Step 16

Activate select faces 

Select these two faces.

Mesh tools-> Refine ->Custom...
R 4
S 1
T 1
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Step 17

Activate select faces 

 Mesh tools->Templates...

Select all these faces. Hold the Ctrl key down to add to or remove from 
the faces that have already been selected.

  

Then use this template.

Step 18

Activate select nodes

 
Mesh tools->Create->Element...
quad4 shell

Step 19

Activate select faces 

 Mesh tools->Templates...

Select all these faces. Hold the Ctrl key down to add to or remove from 
the faces that have already been selected.

  

Then use this template.
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Step 20

Activate select nodes

 
Mesh tools->Create->Element...
quad4 shell

The bottom rounds now have a coarse mesh. Now you will focus 
on finishing the mesh at the boss.

Change the element type from quad4 to tri3, the triangle element and complete the coarse mesh at 
the boss.

When extruded, the triangle elements will form pyramid solids and the quadrilateral elements will form 
hexahedrons.
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Step 21

The  View->Open  cracks shows  that  the  elements  are  not  all 
connected. There are also a lot  of  unused nodes which need to be 
deleted.  Exit open cracks mode to return to the normal editing mode.

Use the Mesh tools->Erase unused nodes. 

Next,  use the  Mesh tools->Merge nearby nodes  with  a  Distance 
tolerance of 0.001 to eliminate the duplicate nodes created during the 
meshing operations.

Step 22

Activate select faces 

Select the entire mesh. 

Mesh tools->Extrude...
Direction +Z
Thickness 30
Number of subdivisions 1

          

Step 23

Activate select faces 

Select the following faces
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Mesh tools->Extrude...
Direction +Z
Thickness 24
Number of subdivisions 1

Step 24

Activate select faces 

Select the following faces

Mesh tools->Extrude...
Direction +Z
Thickness 26
Number of subdivisions 1
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Step 25

Activate select nodes

Select the two nodes that form the end points of the 
rib and do a Mesh tools-> Insert node between 

Repeat the command so that there are three nodes between the rib 
ends. 

Step 26

Activate select nodes

 
Mesh tools->Create->Element...
quad4 shell

Switch the element type to tri3 and complete the rib profile.
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Step 27

Activate select faces 

Select the following faces. 

Mesh tools->Extrude...
Direction -X
Thickness 24
Number of subdivisions 2

Step 28

As this is a coarse mesh use the  Mesh tools->Refine->x2 
to refine the mesh further.
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Step 29

The holes are faceted because the coarse mesh used very few 
nodes to form the circle.

Click in the open space to deselect 
everything then activate select nodes

Edit->Circle selection and drag to 
select the nodes of the hole.

Mesh tools->Fit to sphere/cylinder/cone

Cylinder select
Center
X -112
Y 32
Z 0
Radius 15
Axis
Z select
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Repeat for the other faceted hole
Cylinder select
Center
X -112
Y 32
Z 0
Radius 15
Axis
Z select

Step 30

Click  in  the  open  space  to  deselect  everything  then 
activate select nodes

Edit->Circle selection and drag to select the nodes of 
the hole.

Mesh tools->Fit to sphere/cylinder/cone

Cylinder select
Center
X 0
Y 192
Z 0
Radius 17
Axis
Z select
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Step 31

Click in the open space to deselect everything then activate select nodes

Edit->Circle selection and drag to select the nodes of the round.

Hold the Ctrl key down and drag to deselect as many nodes inside of the round 
as possible.

To deselect the rest switch to  Edit->Rectangle selection 
and drag a box over the blue nodes while holding the Ctrl 
key down. Drag, do not click, otherwise only the topmost 
nodes will be deselected while the remaining nodes behind 
it will continue to remain selected. Use the keyboard arrow 
keys  to  pan  and  page-up/down  to  zoom,  otherwise  you 
might click in open space and deselect everything.

Mesh tools->Fit to sphere/cylinder/cone

Cylinder select
Center
X 112
Y 32
Z 0
Radius 32
Axis
Z select

Repeat for the other round

Mesh tools->Fit to sphere/cylinder/cone

Cylinderselect
Center
X -112
Y 32
Z 0
Radius 32
Axis
Z select
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4.3  Intersecting holes and polygon shapes
Step 1

Identify  the  most  difficult 
features and model them 
before  the  easier 
features. 

In  this  model  the  side 
holes  that  intersect  with 
the through  hole  are  the 
most  difficult,  so this  will 
be modeled first.

Step 2

Mesh tools->Create->Polyline...

Next node's coordinates:
X 12
Y 0
Z 0

Click the Add button

Change Y to 100 click Add
change X to -12 click Add
change Y to 0 click Add
click Close shape

Click the Z arrowhead to view the model parallel to the screen.

View->Fit to window

For now it has been modeled to a width of 24 but later it will be stretched to the 
actual  width of  50.  This was necessary because the left  and right  faces will  be 
rotated in a later step and we didn't want them to penetrate other elements inside 
the mesh.
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Step 3

Mesh tools->Create->Curve generator...

 

D1 16
D2 16

Click OK to exit the ellipse dialog but don't exit the curve generator dialog just yet. 

Change the  Y = 8*sin(p)  into Y= 25 +8*sin(p). This will  move the circle up by 25 
where we would like it to be positioned. Change the Number of elements to 12. Click 
OK to exit the curve generator dialog.

Step 4

Mesh tools->Create->Curve generator...

 

D1 16
D2 16

Click OK to exit the ellipse dialog but don't exit the curve generator dialog. 

Change the  Y = 8*sin(p)  into Y= 75 +8*sin(p), this will  move the circle up by 25 
where we would like it to be positioned. Change the Number of elements to 12. Click 
OK to exit the curve generator dialog.
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Step 5

You will be meshing this with the 2D automesher. But before doing so, you have to delete duplicate 
nodes  created  during  the  meshing  operations  using  Mesh  tools->Merge  nearby  nodes  with  a 
Distance tolerance of 0.001. Note the change in node numbers in the status bar after this command 
has been run.

Mesh tools->Automesh 2D...
Maximum element size 8

The automesher will briefly run in a separate window and 
then close.

Step 6

Select these nodes. Right click on the selected nodes and choose Node coordinates and 
enter 25 for the X coordinate. 

Select these nodes. Right click on the selected nodes and choose Node coordinates and 
enter -25 for the X coordinate. 

The hexagon edge length has now been restored to 50.  It  had to be 
widened because those two faces will be rotated by 30 degrees later.
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Step 7

Activate select nodes 

Select the following nodes and press the delete key. This is to prepare for 
the slot that will be done at a later step.

Select these nodes then right click on one of the selected nodes and choose Node 
coordinates and enter 93 for the Y coordinate.

Likewise, select these nodes then right click on one of the selected nodes and choose 
Node coordinates and enter 7 for the Y coordinate.

Select these nodes. Hold the Ctrl key while selecting them. Right click on one of the 
selected nodes and choose Node coordinates and enter -5 for the X coordinate.
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Select these nodes. Hold the Ctrl key while selecting them. Right click 
on one of the selected nodes and choose Node coordinates and enter 
5 for the X coordinate.

The mesh is now prepared for the 10×7 slot

Step 8

Mesh tools->Create->Element...
quad4 shell

Click the nodes to form quadrilaterals.

Step 9

Activate select faces 

Select the entire mesh. 
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Mesh tools->Extrude...
Direction +Z
Thickness 23.3
Number of subdivisions 3

Step 10

Activate select nodes 

Select the entire mesh, Mesh tools->Move/copy...
  Z 20
 

Step 11

Activate select nodes 

We will be using this co-ordinate information to rotate the right hand face.

Click the Z arrowhead to view the model parallel to the screen.
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Select all the nodes on this face.
Mesh tools->Rotate/copy...
Rotation about point
X 25
Y 0
Z 43.3

Specify rotation angles around X, Y, Z in degrees
0
30
0

Make sure that the copy check-box is not selected.

Step 12

We will be using this co-ordinate information to rotate the left hand face.

Select all the nodes on this face.
Mesh tools->Rotate/copy...
Rotation about point
X -25
Y 0
Z 43.3

Specify rotation angles around X, Y, Z in degrees
0
-30
0

Step 13

Click the Y arrowhead to view the model parallel to the screen.
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Activate select nodes 

Select these nodes. Mesh tools->Fit to sphere/cylinder/cone

Cylinder select
Center
X 0
Y 0
Z 0
Radius 20
Axis
Y select

Step 14

Activate select nodes 

Select the entire model. 
Mesh tools->Rotate/copy...
Rotation about point
X 0
Y 0
Z 0
Specify rotation angles around X, Y, Z in degrees

0
60
0

Copy selected

With the newly created elements selected, repeat the Mesh tools-
>Rotate/copy... with the same parameters and just click Apply.
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Once again with the newly created elements that are selected, repeat the 
Mesh tools->Rotate/copy...

Do it again with the newly created elements that are selected. Repeat 
the Mesh tools->Rotate/copy...

Once more for the final time.   
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That completes the hexagonal shape. Now use the Mesh tools->Merge nearby nodes with a 
Distance tolerance of 0.01 to eliminate duplicate nodes created during the meshing operations. Note 
the change in node numbers in the status bar.

Step 15

Activate select nodes 

Click the Z arrowhead to view the model parallel to the screen.

Edit->Circle selection and drag to select the nodes 
of the holes. Hold the Ctrl key to add to the node 
selection set. Also hold the Shift key to keep a node 
from moving if you happen to click on it.

Then press the 
delete key.
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Step 16

Activate select elements

Select the elements where the slots are to be and press the delete 
key.

Step 17

Activate select elements

Similarly, rotate the model and select the elements where the slots are 
to be and press the delete key.
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Step 18

As this is a coarse mesh use the Mesh tools->Refine->x2 to refine the mesh further.

That concludes this Beginners' Guide.  Hopefully you will now be quite familiar with LISA, and have 
confidence to modify the examples above and even build your own model from scratch.   Additional 
skills, such as importing a CAD model, can be gained from the more advanced companion LISA 
Tutorials and Reference Guide.
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